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proFit demo – a quick guide

This is a quick introduction to the proFit demo disk. It gives a
step by step description of a simple session with proFit  and
shows you some of the application's features.

Installation
To install the proFit demo software, simply double-click the file
“profit  Demo  Installer”.  This  installer  will  create  the  demo
package in a folder called “proFit Demo ƒ” (Fig. 1).

Fig. 1

The proFit 
demo folder

Read the “read me” file for latest news and compatibility alerts.
Then double click the file “proFit Demo” to start the application.

A first session

In the following we describe a typical
session  with  proFit.  We  plot  and
analyse  the  growth  of  the  world’s
population over the last 50 years. The
table to the right shows the number of
inhabitants on this planet in the years
after 1940.

year population in millions
1940 2200
1950 2500
1960 3000
1969 3600
1975 4000
1981 4400
1987 5000
1990 5300
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We must enter the data of Table I into a data window. To do
this, you have to open a new data window:

• Choose “New Data” from the File menu.
An empty data window appears (see Fig. 2).

Fig. 2

An empty data 
window

The data is arranged in horizontal rows and vertical columns.
The  topmost  cell  of  each  column  shows  the  name  of  the
column (by  default  “Column 1”,  “Column 2”,  etc.).  The  cells
below contain the data of each column.
Now you must enter the data from Table I into this window.

• Click on the first empty cell of column 1 and enter the 
first year, 1940.

We fill the first column with the years and the second column
with the population in millions. The first year is 1940.

• Click on the first cell of column 2 and enter the 
population, 2200.

Note that we enter the population in millions.

• Repeat steps 2 and 3 to enter the remaining data in the 
following rows.

Fill in the year and population data as given in Table I. Note that
you can use the arrow keys, the tabulator key, and the return
and enter keys to move from one cell to another.

• Enter the column titles, 'year' and 'population in millions'.
Click the column titles 'Column 1' or 'Column 2' and enter the
new names. Your window should now look as shown in Fig. 3.
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Fig. 3

The data 
window with 
our data
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Now  that  you  have  entered  the  data,  you  can  display  it
graphically:

• Choose “Plot Data...” from the Draw menu.
The dialog box shown in Fig. 4 appears.
Fig. 4

Options for 
plotting data

In  this  dialog  box  you  can  enter  the  range  of  the  plot,  the
columns  to  be  plotted  and  some  other  options.  In  this
introductory session we can use the settings as they are.
A drawing window appears, showing a graph of the data.
Fig. 5

A drawing 
window

proFit demo – a quick guide, page 4



proFit demo – a quick guide, page 5
Now you can edit this graph by using some of proFit’s drawing
features.

• Double-click the vertical axis to change its range.
(Double-click the vertical axis itself, not the numbers to the left
of it!)  A dialog box appears, presenting some options for the
axis. 
Fig. 6

Options for 
the vertical 
axis

You can change a variety of parameters here. Most often you
will use the edit fields “Min” and “Max” near the top of the box.
They define the range of the axis. Another important field is the
“Distance” field that defines the distance between major ticks.

• Enter 0 for “Min” and 6000 for “Max”, then click OK.
The vertical axis of the graph starts now with 0 and ends with
6000.
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Double-click other parts of the graph or its legend to see other
dialog  boxes,  where  you  can  change  more  attributes.  Try
double-clicking the horizontal axis, the centre of the plot, or the
square dot in the legend. You can also double-click any text in
the drawing to change it. Or you can choose any of the drawing
tools at the left  border of the window to add lines, polygons,
text, etc.

Fitting a function to our data

The growth of a population can often be described by an exponential function of
the type

p( t) =p(x0 )× exp
(t−x0 )

t0

 ⎛
 ⎝
 ⎜  ⎞

 ⎠
 ⎟ , (1)

where p(t ) is the population at time t, p(x0) the population at an arbitrary start time x0, and t0 its growth

constant.

Let us try to investigate the validity of this formula for the world's population. We want to find the set of parameters for equation

(1) that describes our data best. 

• Choose “exp” from the Func menu.

This brings the parameters-window to the front. This window gives a description of the built-in exponential function and its

parameters. The function looks like this:

y=A× exp
−(x−x0 )

t0

⎛ 

⎝ 
⎜ ⎞ 

⎠ 
⎟ + const , (2)

This formula is essentially identical to Eq. (1).

The Parameters-window also displays the default values for A, x0, t0, and const. Starting from these values, proFit will look for

a better set of parameters for describing the data. But first you must define which parameters you want to fit and choose good

starting values.

Fig. 7

The Parameters 
for the 
exponential 
function

As mentioned above, the starting time x0 is arbitrary. Let us set it to 1940:

• Click the number beside “x0” in the Parameters-window and enter the starting value 1940.

This defines the parameter's value.

Since x0 is arbitrary, we do not want to fit it:
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• Click on “x0” in the Parameters-window.

When you click on x0, it changes from bold (x0) to normal (x0). This indicates that this parameter is fixed and will not be fitted.

We also hold the constant const fixed at 0, since we don’t need it:

• Click on “const”.

Again, the text changes from bold to normal to indicate that the corresponding parameter will not be fitted.

Before fitting, you should assign starting values to the parameters that  are going to be fitted, in our case  A and  t0. This

increases the speed of the fit and the chances to find the best set of parameters. Reasonable starting values for our problem

can be estimated easily:

A is the population in the year 1940, so we can set it to 2200 millions. –t0 (note the minus, it comes from the different definitions

of Equations (1) and (2)) is the time in which the population increases by a factor e = 2.71. Looking at the plot of the data in the

drawing window, we can easily guess it to be between 50 and 200 years. Let us set t0 to –100:

• Enter the starting values 2200 for A and –100 for t0.

The resulting parameters-window should now be like the one shown in Fig. 8:

Fig. 8

The new 
Parameters

Now we are ready to fit our parameters:

• Choose “Nonlinear Fit” from the Calc menu.

You see a dialog box that lets you choose the data columns you want to fit (Fig. 9):

Fig. 9

Settings for 
fitting

• Click OK to start fitting

The fit only takes some seconds. When it is completed, the fitted parameters are printed in the Results-window.
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The fit yields –54 years for t0 and 2113 millions for  parameter A.

Now we can plot function (1) using these parameters:

• Choose “Plot Function...” from the Draw menu

A dialog box appears, displaying some plotting options (Fig. 10):

Fig. 10

Settings for 
plotting

• Click OK to draw the curve.

The curve is drawn in the graph.

Of course, this sample session could only show some few aspects of proFit’s drawing and fitting capabilities. As you start

working with proFit, you will find many features that have not been mentioned here. They are easy to understand and you will

be able to use most of them without further explanations.

The following chapters will give you a short summary of some of the more unusual features of the application.

Defining your own functions
In  the  previous  sample  session  you  fitted  the  built-in
exponential function to your data set. Fine. But what do you do
if  your  model  function  is  some  lengthy,  complicated
mathematical construction that does not appear among proFit’s
built-in functions in the “Func” menu?
Define your own function! With proFit you can use virtually all
functions you can think of. Let’s look at an example:
Imagine you want to analyse a function of the form

y  =  a sin(x) × ln(x)  + b (3)
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with the parameters a and b. To define it in proFit:

• Choose “New Function” from the File menu.
This opens a new, empty function window.

• Enter the definition of your function in the new window.
The definition of this function looks like this:

function logSine;
begin
y := a[1]*sin(x)*ln(x) + a[2];

end;
The first line of this definition just gives the name (logSine) of the function. Then,
enclosed between  begin and  end, follows the definition of the function. In the
third line the function is calculated (from the variable x and the parameters a[1]
and a[2]), and it is assigned (“:=”) to the variable y.

• Choose “Add To Menu” from the Misc menu.
Doing  so  tells  proFit  to  translate  your  function  into  computer  code.  The  new
function is added to the Func menu, and the parameters-window shows its default
parameters.
After  adding  the  function  to  proFit,  you  can  change  its  parameters  in  the
parameters-window. You can plot the function, use it for fitting, calculate a table of
its values, etc.
To plot it, you first should set its parameters a[1] and a[2] to reasonable values,
e.g. 1 and 0.5: Edit  the fields of the parameter-window. Then you select “Plot
Function...” from the Draw menu. In the dialog box (Fig. 10) that comes up, you
select the plotting range (e.g. the x-axis from 0 to 5 and the y-axis from –2 to 2). If
you still have an open drawing-window from previous work, you should check the
option “Open New Window” in the dialog box (Fig. 10), otherwise you draw your
curve over the old graph.

Our  sample  function  is  not  defined  for  x<=0.  If  you  would  calculate  it  for  a
negative x-value, proFit would report an error. However, the function converges to
y=a[2] for x=0. You may want to expand its definition range by defining y(x) = a[2]
for all x ≤ 0. This can be done easily by the following modified definition. (After
having modified a definition in the Function-window, again select “Add to Menu”
from the Misc menu to add it to proFit.)

function logSine;
begin
if x <= 0
 then y := a[2]
 else y := a[1]*sin(x)*ln(x) + a[2];

end;
This new version of the function shows how you can use the  if statement for
conditional execution.
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Your function could even become much more complicated than that. proFit allows
function definitions that contain more than one statement. You also can define
your  own  variables  and  procedures,  you  can  access  the  data  in  the  data
windows,  and  much  more.  You  can  use  most  elements  of  the  “Pascal”
programming language.
In your demo package you can find more examples of function definitions.

Writing programs
Besides defining functions for fitting and plotting, you can also
define any algorithms for data-generation and -transformation
using the same syntax.
Let us have a quick look at a small program that fills the first
column of a data window with the powers of two:  2, 4, 8, 16,
etc. To define this program, again open a new function-window
(“New Function”  from the file  menu)  and enter  the following
definition.  (Note  that  this  program  starts  with  the  keywordprogram, and not  function. The rest of it follows the same
syntax scheme as a function definition.)
program powersOf2;var i: integer;begin for i := 1 to nrRows do    data[i,1] := 2 ** i;SetColumnName(1,'Powers');end;

To add this program to proFit, again select “Add to Menu” from
the Misc menu.  The program “powersOf2”  will  appear in the
submenu “User” of the Calc menu. To run it, choose it from this
menu. It will fill the first column of the frontmost data window
with the desired values.
For a complete list of syntax elements for writing functions and
programs,  you  can  consult  proFit’s  built-in  help  command
(which you find under the help-balloon menu if you are running
operating System 7 or later, and under the Apple menu for older
operating systems).

Some hints

Printing

proFit was designed for optimum quality results on every printer. For high-end
laser writers PostScript commands are generated. For all other printers (such as
high-resolution ink-jet printers), printing occurs at maximum available resolution.
Therefore, to get best results, you should tell proFit if you are using a PostScript
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printer  or  not.  To  do  this,  select  “Printing/General...”  from  the  submenu
“Preferences” in the File menu. In the dialog box that appears, you should check
or uncheck the check-box “Print drawings using PostScript”.
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Exporting pictures

When you are working with a drawing application such as proFit, you may want to
copy  drawings  from  this  application  into  your  word-processor,  to  make  the
drawings part of some written text.
There are three possibilities to do that:
1. Copy the desired part  of  a  drawing from proFit  and paste it  into  your  text

application.
2. If you are working under System 7, you can create a publisher and subscribe

to it from your text application (if your text application supports this feature).
3. If you are going to print on a PostScript printer, you can save your drawing as

a PostScript- (EPS) file (if your text application supports this feature).

With many conventional applications, drawings copied by method 1 or 2 may print
in poor quality on some printers. With proFit you can export pictures that print fine
in most situations!
In order to take advantage of  this feature,  you should tell  proFit  what kind of
printer  you are  going to  use.  If  you are  using a PostScript  printer,  proFit  will
include PostScript information in its pictures, if  you are using a non-PostScript
printer, proFit can generate so called “high-resolution bitmaps” that print fine on
most printers.
Use “PICT Options...” from the submenu “Preferences” in the File menu. In the
dialog box that comes up (Fig. 11) you can specify if you want PostScript included
in the pictures that you copy from proFit (check “Embedded PostScript”), or if you
want a bitmap (check “Bitmap” and enter your printer’s resolution.
Fig. 11

Picture 
options

For guiding you can use the help balloons under system 7. More information on
the other options is given in the proFit user manual.

More highlights 

Graphic text editor:
Have  you  already  edited  a  text  in  the  Drawing-window?  If  not,  then  open  a
drawing window, select the text tool (the “A” in the toolbox at the right border 
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of the window), and click into the drawing window. In the dialog box that comes
up,  you  can  interactively  create  any  text,  with  any  font,  size,  and  style,  with
arbitrary sub- and superscripts.
Background operation:
Did  you  realise  that  proFit  can  run  “in  the  background”  when  doing  lengthy
operations? If you are e.g. calculating a very large table of a complicated function
or fitting a large set of data, proFit may need some minutes to do this. While
proFit  is  working,  just  click  on  the  window  of  any  other  application.  This
application  will  come  to  the  front  while  proFit  continues  its  work  in  the
background.
External modules:
If you should ever think that you have reached the limits of proFit:
You may have noticed the command “External Modules...” in the Misc menu. With
this command, you can add the code of  a function or  program that you have
written  in  any  compiler  of  yours,  and  use  it  in  the  same way as  any built-in
function or user command.
The proFit demo package includes some code and source examples of external
functiosn and programs in the folder “External Modules”.
And, and, and...:
As you work with proFit, you will discover many other unique features. Have a
look at the files in the folder “Support Files”. Explore!
For more information on proFit contact:

QuantumSoft, Postfach 6613, CH-8023 Zürich
Switzerland
AppleLink: CH0211,   Compuserve: 100022,2221
Internet:  ch0211@applelink.apple.com

PostScript is a registered trademark of Adobe Systems Inc.
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